Says 297 – Diagnostic port fixed (?) Passed eTest

Last Thursday I went to Midas for the fourth time to see if my Hyundai Santa Fe engine computer codes had reset and I could get my eTest so that I could re-new my license plates. Well it didn’t pass as two codes were still not registering, but I did notice that the mechanic had to fiddle with the Diagnostic port to get a reading. He said I should go to the Kia dealer and get a tail pipe emissions test, which I did. But the tech there couldn’t get the Diagnostic port to read so the test failed and the report mentioned an error on pin 16.
Now I was pissed and stormed off to  Woodstock Hyundai  as a faulty Diagnostic port is what I paid the $900.00 for. They made an appointment to get the Santa Fe serviced on Tuesday. I went home and looked online and in the second image, low and behold, pin 16 has to do with POWER… (image with red arrow) Now I’m really pissed, as when I first took it in almost a month ago, I told the service advisor and mechanic to check the diagnostic plug as it was intermittent.
I took the car in yesterday @ 10 am and at 1:00 pm they called and said the Santa Fe was ready and that they even got it etested for me. A courtesy van picked me up and when I got in, I asked them what the problem was and now the manager said that they hooked it up to two of their diagnostic computers and reset the codes and everything checked out fine. He said that third party diagnostic testers (like Midas) are not always accurate and other BS. I said that Kia is the same company that failed the Santa Fe on Thursday, and is the same company that you took it to to pass the test.
He said, well it’s working now, and started off on another tangent. I said it passed the etest, but if it diagnostic port gives me trouble in the future I’ll be back. I knew I wasn’t going to get anywhere with him so I just paid for the emissions re-test, $19.78 as that’s all they charged me, and left

Leave a Reply

Your email address will not be published. Required fields are marked *